macOS “不能安装该软件,因为当前无法从软件更新服务器获得” 解决方法

有些小伙伴无法安装苹果开发者工具 command line tools或者一些其他软件时,安装的时候会提示“不能安装该软件,因为当前无法从软件更新服务器获得”,下面小编就教大家手动来安装。

command line tools

Command Line Tools 是苹果的一个小型独立包,适用于 macOS,为终端扩展了额外的功能。包括但不限于:svn、git、make、GCC、clang、perl、size、strip、strings、libtool、cpp、what、codesign以及其他很多能够在Linux中找到的命令。

对于 macOS 的普通用户来说,主要是使用它的签名功能,就是给没签名的应用/签名失效的应用进行签名啦。因为苹果的应用不签名或者签名失效基本上就会闪退无法运行。

一般来说,大家只需打开终端,然后在终端中执行 xcode-select --install 就会打开安装程序,然后按提示安装即可。但是有些用户的网络和苹果服务器连接不上就会报错:不能安装该软件,因为当前无法从软件更新服务器获得

解决方法

一旦提示:不能安装该软件,因为当前无法从软件更新服务器获得,你就需要手动去苹果开发者下载中心下载 command line tools 的离线安装包了。

  1. 打开苹果开发者中心:https://developer.apple.com(苹果开发者中心的服务器不在国内,所以打开会很慢,耐心等待)
  2. 点击顶部导航最右边的 Account,然后登录自己的 Apple ID
  3. 打开开发者下载中心:https://developer.apple.com/download/more/
  4. 搜索 command line tools(在搜索框中输入完要按一下回车键)
  5. 选择适用于自己 macOS 系统的版本。
  • 10.15.x 可以下载 Command Line Tools for Xcode 11.4 及以上版本
  • 10.14.x 可以下载 Command Line Tools (macOS 10.14) for xxx,其中包含 macOS 10.14的。
  • 10.13.x 可以下载 Command Line Tools (macOS 10.13) for xxx,其中包含 macOS 10.13的。
  • xxxxx其它版同以此类推。
  1. 下载完成后,安装一下,安装完成后就可以使用啦。

下载链接

百度网盘链接: https://pan.baidu.com/s/1YXkYTfj9rDT4QYNzFa8Ilw 提取码: jqp8

© 版权声明
THE END
喜欢就支持一下吧
点赞0
分享
评论 抢沙发