最新版 OpenCore 引导界面没有 10.15 及以下系统选项的解决办法

简单来说就是 OC 维护团队觉得,允许 macOS 加载苹果已经放弃支持的 APFS 版本驱动,会对系统造成安全性问题(或有漏洞),于是他们把 MinDate 和 MinVersion 调整到了最低 macOS 11.0 Big Sur 对应的版本。由于 APFS 文件系统在 macOS 10.14 开始默认采用,到 10.15 的时候变为强制使用,这个修改就导致了 OpenCore 0.7.2 在引导界面无法看到低于 11.0 的系统选项。

解决方法:

修改 EFI 的 config.plist 文件,将inDate/MinVersion的两个值改为 -1 :

最新版 OpenCore 引导界面没有 10.15 及以下系统选项的解决办法

  • Windows 下操作:在 OCAuxiliaryTools 中修改:

最新版 OpenCore 引导界面没有 10.15 及以下系统选项的解决办法

PS:如果你不希望失去 OpenCore 这两个功能为你提供的安全性,也可以填写自定义值,下面是其它可以使用的值参考:

  • 10.13.6(17G66) High Sierra

MinDate:20180621
MinVersion:7480770080000000

  • 10.14.6(18G103) Mojave

MinDate:20190820
MinVersion:9452750070000000

  • 10.15.4(19E287) Catalina

MinDate:20200306
MinVersion:1412101001000000

「注意」上面提到的值,对应标注了系统版本,当你的计算机安装了低于上述版本时,你需要选择一个更低的版本对应值。例如,上述标注 Catalina 的值最低版本 10.15.4,如果你安装的是 10.15.1,那么你需要输入 10.14.6 的值才能保证对引导进入 10.15.1 系统不产生影响

© 版权声明
THE END
喜欢就支持一下吧
点赞1
分享
评论 抢沙发

请登录后发表评论